#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?:(?P<pre1994>[a-hj-np-z][\d]{1,7})|(?P<from1995to2014>[a-z]{3}[\d]{3})|(?P<from2015>[a-z]{2}[\d]{3}[a-z]{2}))"
Local $sString = "C1000000" & @CRLF & _
"FZI454" & @CRLF & _
"AB123CD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")