const regex = new RegExp('(?i)(?:(?P<pre1994>[a-hj-np-z][\\d]{1,7})|(?P<from1995to2014>[a-z]{3}[\\d]{3})|(?P<from2015>[a-z]{2}[\\d]{3}[a-z]{2}))', 'gm')
const str = `C1000000
FZI454
AB123CD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}