package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:(?P<pre1994>[a-hj-np-z][\d]{1,7})|(?P<from1995to2014>[a-z]{3}[\d]{3})|(?P<from2015>[a-z]{2}[\d]{3}[a-z]{2}))`)
var str = `C1000000
FZI454
AB123CD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}