re = /(?i)(?:(?P<pre1994>[a-hj-np-z][\d]{1,7})|(?P<from1995to2014>[a-z]{3}[\d]{3})|(?P<from2015>[a-z]{2}[\d]{3}[a-z]{2}))/m
str = 'C1000000
FZI454
AB123CD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end