// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(?:(?P<pre1994>[a-hj-np-z][\d]{1,7})|(?P<from1995to2014>[a-z]{3}[\d]{3})|(?P<from2015>[a-z]{2}[\d]{3}[a-z]{2}))").unwrap();
let string = "C1000000
FZI454
AB123CD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}