using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]{4}\.[a-zA-Z]{5}).*as ([a-zA-Z]+)";
string input = @"cast (mara.attyp as prodcategory preserving type ) as ProductCategory";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}