$re = '/([a-zA-Z]{4}\.[a-zA-Z]{5}).*as ([a-zA-Z]+)/m';
$str = 'cast (mara.attyp as prodcategory preserving type ) as ProductCategory';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);