re = /([a-zA-Z]{4}\.[a-zA-Z]{5}).*as ([a-zA-Z]+)/m
str = 'cast (mara.attyp as prodcategory preserving type ) as ProductCategory'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end