#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)\<div.*?\>(.*?)\<\/div\>"
Local $sString = "<div id="title">My Title</div>" & @CRLF & _
"<div id="image">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>" & @CRLF & _
"<div id="fullcontent">In this div there are some html elements more</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")