re = /\<div.*?\>(.*?)\<\/div\>/mi
str = '<div id="title">My Title</div>
<div id="image">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>
<div id="fullcontent">In this div there are some html elements more</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end