using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<div.*?\>(.*?)\<\/div\>";
string input = @"<div id=""title"">My Title</div>
<div id=""image"">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>
<div id=""fullcontent"">In this div there are some html elements more</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}