import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<div.*?\\>(.*?)\\<\\/div\\>";
final String string = "<div id=\"title\">My Title</div>\n"
+ "<div id=\"image\">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>\n"
+ "<div id=\"fullcontent\">In this div there are some html elements more</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}