// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mis)\<div.*?\>(.*?)\<\/div\>").unwrap();
let string = "<div id=\"title\">My Title</div>
<div id=\"image\">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>
<div id=\"fullcontent\">In this div there are some html elements more</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}