package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^-]*)$`)
var str = `12345-LATIS
234134-CRISE
13241234-P-ORACLE
134134-ORACLE
1341324-ENS
134134-P-NIBS
134123415-LATIS
11513423-CRISE
1-34555
A-33433
12-23434
5-3451-A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}