import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^-]*)$";
final String string = "12345-LATIS\n"
+ "234134-CRISE\n"
+ "13241234-P-ORACLE\n"
+ "134134-ORACLE\n"
+ "1341324-ENS\n"
+ "134134-P-NIBS\n"
+ "134123415-LATIS\n"
+ "11513423-CRISE\n"
+ "1-34555\n"
+ "A-33433\n"
+ "12-23434\n"
+ "5-3451-A\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}