re = /([^-]*)$/m
str = '12345-LATIS
234134-CRISE
13241234-P-ORACLE
134134-ORACLE
1341324-ENS
134134-P-NIBS
134123415-LATIS
11513423-CRISE
1-34555
A-33433
12-23434
5-3451-A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end