# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^-]*)$"
test_str = ("12345-LATIS\n"
"234134-CRISE\n"
"13241234-P-ORACLE\n"
"134134-ORACLE\n"
"1341324-ENS\n"
"134134-P-NIBS\n"
"134123415-LATIS\n"
"11513423-CRISE\n"
"1-34555\n"
"A-33433\n"
"12-23434\n"
"5-3451-A\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.