using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((0[1-9]|1[012])[- \/.]?(0[1-9]|[12][0-9]|3[01])[- \/.]?(19|20)\d\d)|((((0?[13578])|(1[02]))[- \/.]?((0?[1-9])|([12][0-9])|(3[01]))|((0?[469])|(11))[- \/.]?((0?[1-9])|([12][0-9])|(30))|(0?[2])[- \/.]?((0?[1-9])|([1][0-9])|([2][0-8])))[- \/.]?(19\d{2}|20\d{2}))|(((0?[2]))[- \/.]?((0?[1-9])|([12][0-9]))[- \/.]?((19|20)(04|08|[2468][048]|[13579][26])|2000)))$";
string input = @"02022014
222014";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}