package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((0[1-9]|1[012])[- \/.]?(0[1-9]|[12][0-9]|3[01])[- \/.]?(19|20)\d\d)|((((0?[13578])|(1[02]))[- \/.]?((0?[1-9])|([12][0-9])|(3[01]))|((0?[469])|(11))[- \/.]?((0?[1-9])|([12][0-9])|(30))|(0?[2])[- \/.]?((0?[1-9])|([1][0-9])|([2][0-8])))[- \/.]?(19\d{2}|20\d{2}))|(((0?[2]))[- \/.]?((0?[1-9])|([12][0-9]))[- \/.]?((19|20)(04|08|[2468][048]|[13579][26])|2000)))$`)
var str = `02022014
222014`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}