import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((0[1-9]|1[012])[- \\/.]?(0[1-9]|[12][0-9]|3[01])[- \\/.]?(19|20)\\d\\d)|((((0?[13578])|(1[02]))[- \\/.]?((0?[1-9])|([12][0-9])|(3[01]))|((0?[469])|(11))[- \\/.]?((0?[1-9])|([12][0-9])|(30))|(0?[2])[- \\/.]?((0?[1-9])|([1][0-9])|([2][0-8])))[- \\/.]?(19\\d{2}|20\\d{2}))|(((0?[2]))[- \\/.]?((0?[1-9])|([12][0-9]))[- \\/.]?((19|20)(04|08|[2468][048]|[13579][26])|2000)))$";
final String string = "02022014\n"
+ "222014";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}