# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?;.*)A(.*?;)/\1X\2/gm;t' <<< "ABCD ABCD; ABCD ABCD; ABCD ABCD"