const regex = /(.*?;.*)A(.*?;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?;.*)A(.*?;)', 'gm')
const str = `ABCD ABCD; ABCD ABCD; ABCD ABCD`;
const subst = `\1X\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);