use strict;
my $str = 'ABCD ABCD; ABCD ABCD; ABCD ABCD';
my $regex = qr/(.*?;.*)A(.*?;)/mp;
my $subst = '\\1X\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";