$re = '/(.*?;.*)A(.*?;)/m';
$str = 'ABCD ABCD; ABCD ABCD; ABCD ABCD';
$subst = "\1X\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;