using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?;.*)A(.*?;)";
string substitution = @"\1X\2";
string input = @"ABCD ABCD; ABCD ABCD; ABCD ABCD";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}