const regex = /(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>)\\s*([^<]*[^\\s<])\\s*(?=<)|(?<=>)\\s*', 'gm')
const str = `<?xml version="1.0" encoding="UTF-8"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading> * + Reminder + * </heading>
<body>Don't forget
me this weekend!
</body>
</note>
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);