import re
regex = re.compile(r"(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*", flags=re.MULTILINE)
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<note>\n"
" <to>Tove</to>\n"
" <from>Jani</from>\n"
" <heading> * + Reminder + * </heading>\n"
" <body>Don't forget\n"
" me this weekend! \n"
" </body>\n"
"</note> \n\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)