using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:[uo7])+[\s]*[wn]+[\s]*(?:[uo7])+)+";
string input = @"owo
uwu
oooowwwoooo
uuuuuwwwuuuu
UUUUUUUUWWWWWWWUUUUUU
OOOOO WWWWW OOOOOOOOO
7w7
7 w7
7 w 7
unu
u n u
7n7
7 n 7";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}