use strict;
my $str = 'owo
uwu
oooowwwoooo
uuuuuwwwuuuu
UUUUUUUUWWWWWWWUUUUUU
OOOOO WWWWW OOOOOOOOO
7w7
7 w7
7 w 7
unu
u n u
7n7
7 n 7';
my $regex = qr/(?:(?:[uo7])+[\s]*[wn]+[\s]*(?:[uo7])+)+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}