// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:(?:[uo7])+[\s]*[wn]+[\s]*(?:[uo7])+)+").unwrap();
let string = "owo
uwu
oooowwwoooo
uuuuuwwwuuuu
UUUUUUUUWWWWWWWUUUUUU
OOOOO WWWWW OOOOOOOOO
7w7
7 w7
7 w 7
unu
u n u
7n7
7 n 7";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}