const regex = /(?:(?:[uo7])+[\s]*[wn]+[\s]*(?:[uo7])+)+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[uo7])+[\\s]*[wn]+[\\s]*(?:[uo7])+)+', 'gmi')
const str = `owo
uwu
oooowwwoooo
uuuuuwwwuuuu
UUUUUUUUWWWWWWWUUUUUU
OOOOO WWWWW OOOOOOOOO
7w7
7 w7
7 w 7
unu
u n u
7n7
7 n 7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}