import Foundation
let pattern = #"(?:(?:[uo7])+[\s]*[wn]+[\s]*(?:[uo7])+)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
owo
uwu
oooowwwoooo
uuuuuwwwuuuu
UUUUUUUUWWWWWWWUUUUUU
OOOOO WWWWW OOOOOOOOO
7w7
7 w7
7 w 7
unu
u n u
7n7
7 n 7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)