use strict;
my $str = 'Regex Explained:
We often use the technique .*? similar as * in windows explorer search.
In this example, we "know" that our input XML has exactly 3 V Tags and we want to know only the value of the third one. This is why we use () around the .*? at the end of our regex, it sets the first matchgroup to the third V Tag value.
Here is our input XML:
<xml>
<V>ABCD</V>
<X>notused</X>
<V>FGEH</V>
<Y>notused</Y>
<V>3</V>
</xml>
';
my $regex = qr`(?s)<V>.*?</V>.*<V>.*?</V>.*<V>(.*?)</V>`p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}