import Foundation
let pattern = #"(?s)<V>.*?</V>.*<V>.*?</V>.*<V>(.*?)</V>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Regex Explained:
We often use the technique .*? similar as * in windows explorer search.
In this example, we "know" that our input XML has exactly 3 V Tags and we want to know only the value of the third one. This is why we use () around the .*? at the end of our regex, it sets the first matchgroup to the third V Tag value.
Here is our input XML:
<xml>
<V>ABCD</V>
<X>notused</X>
<V>FGEH</V>
<Y>notused</Y>
<V>3</V>
</xml>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}