$re = '`(?s)<V>.*?</V>.*<V>.*?</V>.*<V>(.*?)</V>`';
$str = 'Regex Explained:
We often use the technique .*? similar as * in windows explorer search.
In this example, we "know" that our input XML has exactly 3 V Tags and we want to know only the value of the third one. This is why we use () around the .*? at the end of our regex, it sets the first matchgroup to the third V Tag value.
Here is our input XML:
<xml>
<V>ABCD</V>
<X>notused</X>
<V>FGEH</V>
<Y>notused</Y>
<V>3</V>
</xml>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);