# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)<V>.*?</V>.*<V>.*?</V>.*<V>(.*?)</V>"
test_str = ("Regex Explained: \n"
"We often use the technique .*? similar as * in windows explorer search. \n"
"In this example, we \"know\" that our input XML has exactly 3 V Tags and we want to know only the value of the third one. This is why we use () around the .*? at the end of our regex, it sets the first matchgroup to the third V Tag value. \n"
"Here is our input XML:\n\n"
"<xml>\n"
"<V>ABCD</V>\n"
"<X>notused</X>\n"
"<V>FGEH</V>\n"
"<Y>notused</Y>\n"
"<V>3</V>\n"
"</xml>\n\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.