// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<V>.*?</V>.*<V>.*?</V>.*<V>(.*?)</V>").unwrap();
let string = "Regex Explained:
We often use the technique .*? similar as * in windows explorer search.
In this example, we \"know\" that our input XML has exactly 3 V Tags and we want to know only the value of the third one. This is why we use () around the .*? at the end of our regex, it sets the first matchgroup to the third V Tag value.
Here is our input XML:
<xml>
<V>ABCD</V>
<X>notused</X>
<V>FGEH</V>
<Y>notused</Y>
<V>3</V>
</xml>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}