#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/dignity-care-reports\/[a-z-]+(\/?)"
Local $sString = "/dignity-care-reports/" & @CRLF & _
"/dignity-in-care-reports/" & @CRLF & _
"/dignity-care-reports/buckingham/" & @CRLF & _
"/dignity-care-reports/winslow/" & @CRLF & _
"/dignity-care-reports/stoke-mandeville"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")