re = /^\/dignity-care-reports\/[a-z-]+(\/?)/m
str = '/dignity-care-reports/
/dignity-in-care-reports/
/dignity-care-reports/buckingham/
/dignity-care-reports/winslow/
/dignity-care-reports/stoke-mandeville'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end