// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/dignity-care-reports\/[a-z-]+(\/?)").unwrap();
let string = "/dignity-care-reports/
/dignity-in-care-reports/
/dignity-care-reports/buckingham/
/dignity-care-reports/winslow/
/dignity-care-reports/stoke-mandeville";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}