using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{1,5})(_|__)([a-zA-Z0-9-]{1,99})";
string input = @"42_foo-bar-baz
11111_qux
42__foo-bar-baz
11111__qux";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}