re = /([0-9]{1,5})(_|__)([a-zA-Z0-9-]{1,99})/m
str = '42_foo-bar-baz
11111_qux
42__foo-bar-baz
11111__qux'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end