const regex = /([0-9]{1,5})(_|__)([a-zA-Z0-9-]{1,99})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{1,5})(_|__)([a-zA-Z0-9-]{1,99})', 'gm')
const str = `42_foo-bar-baz
11111_qux
42__foo-bar-baz
11111__qux`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}