package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{1,5})(_|__)([a-zA-Z0-9-]{1,99})`)
var str = `42_foo-bar-baz
11111_qux
42__foo-bar-baz
11111__qux`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}