// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{1,5})(_|__)([a-zA-Z0-9-]{1,99})").unwrap();
let string = "42_foo-bar-baz
11111_qux
42__foo-bar-baz
11111__qux";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}