use strict;
my $str = '[\'lo\', \'ens4\', \'lo\', \'tun0\', \'lo\', \'tun1\', \'lo\']
(0.0, 0.0, 0.0)';
my $regex = qr/'lo'(?:,\s*)?|[][')(]|(?:,\s*)?'lo'/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";