// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'lo'(?:,\s*)?|[][')(]|(?:,\s*)?'lo'").unwrap();
let string = "['lo', 'ens4', 'lo', 'tun0', 'lo', 'tun1', 'lo']
(0.0, 0.0, 0.0)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}