import re
regex = re.compile(r"'lo'(?:,\s*)?|[][')(]|(?:,\s*)?'lo'", flags=re.MULTILINE)
test_str = ("['lo', 'ens4', 'lo', 'tun0', 'lo', 'tun1', 'lo']\n"
"(0.0, 0.0, 0.0)")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)