import Foundation
let pattern = #"'lo'(?:,\s*)?|[][')(]|(?:,\s*)?'lo'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
['lo', 'ens4', 'lo', 'tun0', 'lo', 'tun1', 'lo']
(0.0, 0.0, 0.0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)