const regex = /\s\"[^\"]+"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s\\"[^\\"]+"', 'g')
const str = `"name": "john doe"`;
const subst = `xxx`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);